CanBeCutWithVoid Method


Indicates if the element can be cut by an instance with unattached voids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public static bool CanBeCutWithVoid(
	Element element
)
Visual Basic
Public Shared Function CanBeCutWithVoid ( _
	element As Element _
) As Boolean
Visual C++
public:
static bool CanBeCutWithVoid(
	Element^ element
)

Parameters

element
Type: Autodesk.Revit.DB Element
The element to be cut

Return Value

Returns true if the element can be cut by an instance with unattached voids.

Remarks

Elements in a project can be cut if they are host elements or family instances with a category Generic Model or one of the structural categories.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also