Creates a new curve loop as a transformed copy of the input curve loop.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curveLoop
- Type: Autodesk.Revit.DB CurveLoop
The input curve loop.
- transform
- Type: Autodesk.Revit.DB Transform
The transformation.
Return Value
The new curve loop.Remarks
The newly created CurveLoop is guaranteed to be valid with all consituent curves contiguous (assuming that the curves were contiguous in the input curve loop).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero. |