Splits the straight into two at the passed in point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- position
- Type: Autodesk.Revit.DB XYZ
The position to split in the straight.
Return Value
Returns the ElementId of the new straight.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The position is not on the straight. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The part is not a straight. |