Creates an object representing element or subelement.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since:
2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
-
Type:
Autodesk.Revit.DB
Document
The document.
- reference
-
Type:
Autodesk.Revit.DB
Reference
The reference that identifies element or subelement.
Return Value
The newly created subelement.Remarks
If %reference% points to linked document:
- The GetReference method of the newly created subelement will return the local reference in the linked document.
- The Document property of the newly created subelement will return the linked document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | reference does not identify a valid element or subelement. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |