Factory method - creates manager object for the given view
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
View for which manager object is created or retrieved
- numberOfMeasurements
- Type: System Int32
Total number of measurements in the calculated results. This number defines the length of value arrays in ValueAtPoint objects
Return Value
Manager object for the view passed in the argumentExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | numberOfMeasurements is less than one |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | View is not allowed to display analysis results or a manager object for this view already exists |