ElementPhaseStatusFilter Constructor (ElementId, ICollection(ElementOnPhaseStatus))


Constructs a new instance of a file to match elements that have a given phase statuses on the input phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public ElementPhaseStatusFilter(
	ElementId phaseId,
	ICollection<ElementOnPhaseStatus> phaseStatuses
)
Visual Basic
Public Sub New ( _
	phaseId As ElementId, _
	phaseStatuses As ICollection(Of ElementOnPhaseStatus) _
)
Visual C++
public:
ElementPhaseStatusFilter(
	ElementId^ phaseId, 
	ICollection<ElementOnPhaseStatus>^ phaseStatuses
)

Parameters

phaseId
Type: Autodesk.Revit.DB ElementId
Id of the phase.
phaseStatuses
Type: System.Collections.Generic ICollection ElementOnPhaseStatus
Target statuses.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also