Checks whether the specified element can be used as a host for the railing. The host can be:
- stairs
- stairs component
- ramp
- floor
- slab edge
- wall
- roof
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostId
- Type: Autodesk.Revit.DB ElementId
Element id to check.
Return Value
True if the element can be used as host for the railing.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |