SetGraphicOverrides Method (WorksetId, WorksharingDisplayGraphicSettings)


Sets the graphic overrides assigned to elements in a particular user workset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public void SetGraphicOverrides(
	WorksetId worksetId,
	WorksharingDisplayGraphicSettings overrides
)
Visual Basic
Public Sub SetGraphicOverrides ( _
	worksetId As WorksetId, _
	overrides As WorksharingDisplayGraphicSettings _
)
Visual C++
public:
void SetGraphicOverrides(
	WorksetId^ worksetId, 
	WorksharingDisplayGraphicSettings^ overrides
)

Parameters

worksetId
Type: Autodesk.Revit.DB WorksetId
The workset of interest, which must be a user workset.
overrides
Type: Autodesk.Revit.DB WorksharingDisplayGraphicSettings
The desired graphic overrides for this workset.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException worksetId does not correspond to a user workset in the document containing this WorksharingDisplaySettings.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also