Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to match all elements which are of the given categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryIds
- Type: System.Collections.Generic ICollection ElementId
The category ids to match.
- inverted
- Type: System Boolean
True if the filter should match all elements which are not of the given categories.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more categories was not valid for filtering. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |