SetCellType Method (Int32, CellType)


Sets a column's cell type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public void SetCellType(
	int nCol,
	CellType type
)
Visual Basic
Public Sub SetCellType ( _
	nCol As Integer, _
	type As CellType _
)
Visual C++
public:
void SetCellType(
	int nCol, 
	CellType type
)

Parameters

nCol
Type: System Int32
type
Type: Autodesk.Revit.DB CellType

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The given column number nCol is invalid.
Autodesk.Revit.Exceptions ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions InvalidOperationException This operation is forbidden for cells in standard schedule body sections.

See Also