The base class for DirectContext3D index streams, which are used to write vertex indices into buffers.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
There is a corresponding stream type for each type of primitive (point, line, or triangle). The process of putting vertex indices into a buffer involves using a stream-buffer pair as follows (see Autodesk::Revit::DB::DirectContext3D::IndexBuffer).
- Map the index buffer.
- Get a stream for the appropriate primitive type from the buffer.
- Add sequences of indices corresponding to primitives of the same type to the stream. The indices will be written into the buffer that was used to create the stream.
- Unmap the buffer.
Alternatively to using streams, it is possible to write data into a buffer using a handle to its mapped memory.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamLine
Autodesk.Revit.DB.DirectContext3D IndexStreamPoint
Autodesk.Revit.DB.DirectContext3D IndexStreamTriangle
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamLine
Autodesk.Revit.DB.DirectContext3D IndexStreamPoint
Autodesk.Revit.DB.DirectContext3D IndexStreamTriangle