Gets the subelement referenced by a unique id string.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- uniqueId
- Type: System String
The unique id that identifies element or subelement.- UniqueId
Return Value
The subelement referenced by the input argument.Remarks
a null reference ( Nothing in Visual Basic) will be returned if the input id string doesn't reference to a valid element or subelement.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |