The base class for DirectContext3D vertex streams, which are used to write vertex data into buffers.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
For each type of vertex (e.g., Autodesk::Revit::DB::DirectContext3D::VertexPositionNormal), there is a corresponding stream type. The process of putting vertex data into a buffer involves using a stream-buffer pair as follows (see Autodesk::Revit::DB::DirectContext3D::VertexBuffer).
- Map the vertex buffer.
- Get a stream of the appropriate type from the buffer.
- Add vertices of the same type to the stream. They will be written into the buffer that was used to create the stream.
- Unmap the buffer.
Alternatively to using streams, it is possible to write data into a buffer using a handle to its mapped memory.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPosition
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionColored
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormal
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormalColored
Autodesk.Revit.DB.DirectContext3D VertexStream
Autodesk.Revit.DB.DirectContext3D VertexStreamPosition
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionColored
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormal
Autodesk.Revit.DB.DirectContext3D VertexStreamPositionNormalColored