Sets a new parameter value of this subelement given a parameter id.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since:
2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameterId
-
Type:
Autodesk.Revit.DB
ElementId
Parameter id.
- pValue
-
Type:
Autodesk.Revit.DB
ParameterValue
New value for the parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | parameterId does not identify a valid parameter of this subelement. -or- The parameter parameterId is not modifiable for this subelement. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |