Obtains the spatial element boundary curves as an array of CurveLoops, needed for processing into IFC-specific elements later.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- spatialElement
- Type: Autodesk.Revit.DB SpatialElement
The spatial element.
- options
- Type: Autodesk.Revit.DB SpatialElementBoundaryOptions
The options for extraction of the boundaries.
- cleanCurves
- Type: System Boolean
If true, curves will be trimmed to meet their neighbors. If false, no trimming will take place.
Return Value
The list of CurveLoops.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | Unable to get boundary curve loops for the spatial element. |