Contains markers and text settings for analysis display style element.
Namespace:
Autodesk.Revit.DB.Analysis
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Examples
Copy
C#
// Settings relating to the marker shape and size and the display of values
AnalysisDisplayMarkersAndTextSettings markerSettings = new AnalysisDisplayMarkersAndTextSettings();
markerSettings.MarkerSize = .05;
markerSettings.MarkerType = AnalysisDisplayStyleMarkerType.Triangle;
markerSettings.Rounding = .01;
// Settings relating to the marker color
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
colorSettings.MaxColor = new Color(255, 0, 0);
colorSettings.MinColor = new Color(0, 255, 255);
// Settings relating to the legend
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.Rounding = .01;
// Create the new display style
AnalysisDisplayStyle ads = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Markers 1", markerSettings, colorSettings, legendSettings);
// Assign the new display style to the current view
doc.ActiveView.AnalysisDisplayStyleId = ads.Id;
Copy
VB.NET
' Settings relating to the marker shape and size and the display of values
Dim markerSettings As New AnalysisDisplayMarkersAndTextSettings()
markerSettings.MarkerSize = 0.05
markerSettings.MarkerType = AnalysisDisplayStyleMarkerType.Triangle
markerSettings.Rounding = 0.01
' Settings relating to the marker color
Dim colorSettings As New AnalysisDisplayColorSettings()
colorSettings.MaxColor = New Color(255, 0, 0)
colorSettings.MinColor = New Color(0, 255, 255)
' Settings relating to the legend
Dim legendSettings As New AnalysisDisplayLegendSettings()
legendSettings.Rounding = 0.01
' Create the new display style
Dim ads As AnalysisDisplayStyle = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Markers 1", markerSettings, colorSettings, legendSettings)
' Assign the new display style to the current view