Sets the default element type id of the given DefaultElementType id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- defaultTypeId
- Type: Autodesk.Revit.DB ElementTypeGroup
The default element type id.
- typeId
- Type: Autodesk.Revit.DB ElementId
The element type id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element type id typeId is invalid for the give DefaultElementType id defaultTypeId. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |