SetBarTypeDiameters Method


Sets all input diameters from diametersOpt in current RebarBarType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.13)
Since: 2018.1

Syntax

C#
public void SetBarTypeDiameters(
	BarTypeDiameterOptions diametersOpt
)
Visual Basic
Public Sub SetBarTypeDiameters ( _
	diametersOpt As BarTypeDiameterOptions _
)
Visual C++
public:
void SetBarTypeDiameters(
	BarTypeDiameterOptions^ diametersOpt
)

Parameters

diametersOpt
Type: Autodesk.Revit.DB BarTypeDiameterOptions
The input diameters are validated as follows : barDiameter is both positive and no more than the smallest value of 1.0 and the input bend diameters. Each bend diameter is smaller than 99.0 and bigger than barDiameter.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentOutOfRangeException the diameters ranges in diametersOpt are not acceptable.
Autodesk.Revit.Exceptions DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also