Checks if resolution of the failures by deleting given collection of elements is permitted.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- idsToDelete
- Type: System.Collections.Generic IList ElementId
The Ids of elements to be deleted.
- reason
- Type: System String %
A localized string explaining reason why the elements cannot be deleted.
Return Value
True if resolution of the failures by deleting given elements is permittedRemarks
Method does not confirm if deletion of the elements will or may resolve the failure - it simply verifies that given elements can be deleted in the current state of the document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |