Returns the width of a curve loop if it is rectangular with respect to the projection plane.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- plane
- Type: Autodesk.Revit.DB Plane
The plane to which the curves will be projected.
Return Value
The width.Remarks
The width is determined by the U extents of the UV curve created by from the curve loop plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The curve loop is not rectangular when projected to the input plane. |