Returns one or more properties for legacy (created in R2012 or before) Stairs.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
- pElement
- Type: Autodesk.Revit.DB Element
the legacy stair.
- pNumRisers
- Type: System Int32 %
Number of Risers in the Stair.
- pNumTreads
- Type: System Int32 %
Number of Treads in the Stair.
- pRiserHeight
- Type: System Double %
Riser Height of the risers in the Stair.
- pTreadLength
- Type: System Double %
Tread length of the treads in the Stair.
- pMinTreadLength
- Type: System Double %
Minimum Tread length of the treads in the Stair.
- pNosingLength
- Type: System Double %
Nosing length of the treads in the Stair.
- pWaistThickness
- Type: System Double %
Waist thickness of the flight of stair.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |