Create Method (XYZ, XYZ)


Constructs a BRepBuilderEdgeGeometry representing a straight line between the two given points.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2016

Syntax

C#
public static BRepBuilderEdgeGeometry Create(
	XYZ startPoint,
	XYZ endPoint
)
Visual Basic
Public Shared Function Create ( _
	startPoint As XYZ, _
	endPoint As XYZ _
) As BRepBuilderEdgeGeometry
Visual C++
public:
static BRepBuilderEdgeGeometry^ Create(
	XYZ^ startPoint, 
	XYZ^ endPoint
)

Parameters

startPoint
Type: Autodesk.Revit.DB XYZ
endPoint
Type: Autodesk.Revit.DB XYZ

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentsInconsistentException The vectors startPoint and endPoint are coincident.

See Also