GetAllExternalResourceReferences Method (Document, ExternalResourceType)


Gets the ids of all elements which refer to a specific type of external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public static ISet<ElementId> GetAllExternalResourceReferences(
	Document document,
	ExternalResourceType resourceType
)
Visual Basic
Public Shared Function GetAllExternalResourceReferences ( _
	document As Document, _
	resourceType As ExternalResourceType _
) As ISet(Of ElementId)
Visual C++
public:
static ISet<ElementId^>^ GetAllExternalResourceReferences(
	Document^ document, 
	ExternalResourceType^ resourceType
)

Parameters

document
Type: Autodesk.Revit.DB Document
The Revit Document containing the external resource references.
resourceType
Type: Autodesk.Revit.DB ExternalResourceType
The type of external resource.

Return Value

The ids of all elements which refer to external resources of the specified type.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also