Sets the boundary and path curves of the sketched landing.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document that owns the landing.
- boundaryCurveLoop
- Type: Autodesk.Revit.DB CurveLoop
The closed boundary curves of the landing.
- pathCurveLoop
- Type: Autodesk.Revit.DB CurveLoop
The path curves of the landing, can be an empty CurveLoop.
Remarks
This should be run from within an open transaction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The boundaryCurveLoop is not closed. -or- The input boundaryCurveLoop contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- The input pathCurveLoop contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- Failed to create curve element by the boundaryCurveLoop or pathCurveLoop. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |