Gets the curve loop corresponding to the hole in the wall made by the instance.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pADoc
- Type: Autodesk.Revit.DB Document
The document.
- pVWall
- Type: Autodesk.Revit.DB Wall
The host wall.
- pFamInst
- Type: Autodesk.Revit.DB FamilyInstance
The hosted instance.
- pCutDir
- Type: Autodesk.Revit.DB XYZ %
The direction of the hole relative to the location of the curve loop.
Return Value
The opening in the wall.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |