Attaches the hanger rod to another bearer hanger.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hangerId
- Type: Autodesk.Revit.DB ElementId
Id of the bearer hanger to which the rod attaches.
- rodIndex
- Type: System Int32
The index of the rod.
- position
- Type: Autodesk.Revit.DB XYZ
The position of the rod end. It should be on bearer centerline.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The hanger is not a bearer hanger. -or- the point is not on hanger bearer centerline. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count. |