Creates a new boundary line as an Area border.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sketchPlane
- Type: Autodesk.Revit.DB SketchPlane
The sketch plane.
- geometryCurve
- Type: Autodesk.Revit.DB Curve
The geometry curve on which the boundary line are
- areaView
- Type: Autodesk.Revit.DB ViewPlan
The View for the new Area
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the sketch plane does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the area view does not exist in the given document. |