Look up a column attachment by specifying the target id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- column
- Type: Autodesk.Revit.DB FamilyInstance
A column.
- targetId
- Type: Autodesk.Revit.DB ElementId
Id of a target element.
Return Value
The column attachment attaching the column to the target, or a null reference ( Nothing in Visual Basic) if there is no such attachment.Remarks
May return either a top or base attachment.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |