Gets worksharing information about an element to display in an in-canvas tooltip.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document containing the element
- elementId
- Type: Autodesk.Revit.DB ElementId
The id of the element in question
Return Value
Worksharing information about the specified element.Remarks
If there is no element corresponding to the given id, then all the strings returned in WorksharingTooltipInfo are empty.
The return value may not be dependable in the middle of a transaction. See the remarks on WorksharingUtils for more details.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |