RevitLinkType Class


This class represents another Revit Document ("link") brought into the current one ("host").

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012

Syntax

C#
public class RevitLinkType : ElementType
Visual Basic
Public Class RevitLinkType _
	Inherits ElementType
Visual C++
public ref class RevitLinkType : public ElementType

Remarks

Revit links can be nested - There can exist linked files which themselves contain links. A "top-level" link is one linked directly into the host, while a "nested" link is linked into some parent link. This can go through arbitrarily many layers. Some functions give the example "A -> B -> C". This means that there is a host file, A, which has a top-level link, B, and a nested link C which has been linked into B as an attachment.

Inheritance Hierarchy

See Also