Creates an object that can be passed to DBView::setBackground function to set the background of the Gradient type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- skyColor
- Type: Autodesk.Revit.DB Color
The top of the sky gradient if the sky is visible.
- horizonColor
- Type: Autodesk.Revit.DB Color
The bottom or the sky gradient if the sky is visible, or the top of the ground gradient otherwise.
- groundColor
- Type: Autodesk.Revit.DB Color
The ground color if the sky is visible (ground shown in uniform color), or the bottom of the ground gradient if the sky is not visible.
Return Value
New background object to pass to DBView::setBackground.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |