Constructs a extension instance with a control and ok action handler.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- userControl
- Type: System.Windows.Controls UserControl
The control.
- onOK
- Type: Autodesk.Revit.UI TabbedDialogAction
The ok action handler.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when userControl or onOK is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when userControl is already bound to another tabbed dialog. |