Finds the analytical connection type by its name.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DB Document
The document where the analytical conneciton type is expected.
- name
- Type: System String
The name of the expected analytical connection type.
Return Value
The element id of matched analytical connection type, otherwise invalidElementId.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name is an empty string. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |