Constructs a new instance of an ElementParameterFilter, with the option to match all elements not passing a given filter rule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filterRule
- Type: Autodesk.Revit.DB FilterRule
The rule applied to test if the element passes this filter.
- inverted
- Type: System Boolean
True if the filter should match all elements which do not pass the filter rule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |