Gets the FaceRegions in the existing face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- cda
- Type: Autodesk.Revit.DB Document
The Document.
- referenceOfFace
- Type: Autodesk.Revit.DB Reference
The Reference of the existing face.
Return Value
The FaceRegions in the existing face, or an empty collection if no FaceRegions are found.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The Reference is not a Face Reference. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |