Sets the rule's categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categories
- Type: System.Collections.Generic ICollection ElementId
The categories.
Return Value
True if the set of categories was changed, false if no change was necessary.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One of the given categories is not filterable |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |