Scale a profile of the form, by a specified origin and scale factor.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profileIndex
- Type: System Int32
Index to specify the profile.
- factor
- Type: System Double
The scale factor, it should be large than zero.
- origin
- Type: Autodesk.Revit.DB XYZ
The origin where scale happens.