Returns a stable reference to the start point or the end point of the curve.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- index
- Type: System Int32
Use 0 for the start point; 1 for the end point.
Return Value
Reference to the point or a null reference ( Nothing in Visual Basic) if reference cannot be obtained.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the object is internally marked as read-only or this curve is unbound. |