Returns the major side faces for this host object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostObject
- Type: Autodesk.Revit.DB HostObject
The host object.
- side
- Type: Autodesk.Revit.DB ShellLayerType
The side of the host object.
Return Value
An array of references to the faces which are on the given side of this element.Remarks
This utility supports host objects whose CompoundStructure is nominally oriented vertically. It outputs faces which are at the boundary of the CompoundStructure (such as Walls and FaceWalls).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This host object does not support access to side faces. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |