Create Method (Document, String, ICollection(ElementId), ElementFilter)


Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2019

Syntax

C#
public static ParameterFilterElement Create(
	Document aDocument,
	string name,
	ICollection<ElementId> categories,
	ElementFilter elementFilter
)
Visual Basic
Public Shared Function Create ( _
	aDocument As Document, _
	name As String, _
	categories As ICollection(Of ElementId), _
	elementFilter As ElementFilter _
) As ParameterFilterElement
Visual C++
public:
static ParameterFilterElement^ Create(
	Document^ aDocument, 
	String^ name, 
	ICollection<ElementId^>^ categories, 
	ElementFilter^ elementFilter
)

Parameters

aDocument
Type: Autodesk.Revit.DB Document
The document in which to create the ParameterFilterElement.
name
Type: System String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic ICollection ElementId
The categories for the new ParameterFilterElement.
elementFilter
Type: Autodesk.Revit.DB ElementFilter
The rules for the new ParameterFilterElement, represented as an ElementFilter The ElementFilter must be either an ElementParameterFilter or an ElementLogicalFilter containing only ElementParameterFilters and other ElementLogicalFilters. The former can be used if desired to represent a single FilterRule, while the latter allows arbitrary logical combinations of FilterRules using AND/OR operations. For example: "Length > 100.0" AND ("Area < 200.0" OR "Volume < 500.0").

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException name is an empty string or contains only whitespace. -or- name cannot include prohibited characters. -or- The given value for name is already in use as a filter element name. -or- One of the given rules refers to a parameter that does not apply to this filter's categories.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions ArgumentsInconsistentException The ElementFilter is not acceptable for use by a ParameterFilterElement.

See Also