SetPosition Method


Sets the position for a specified handle. This information is set to the rebar after the API execution is finished successfully.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public void SetPosition(
	int handleTag,
	XYZ position
)
Visual Basic
Public Sub SetPosition ( _
	handleTag As Integer, _
	position As XYZ _
)
Visual C++
public:
void SetPosition(
	int handleTag, 
	XYZ^ position
)

Parameters

handleTag
Type: System Int32
The tag of the handle.
position
Type: Autodesk.Revit.DB XYZ
Position of the handle.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The input point lies outside of Revit design limits.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also