Identifies if a reference may be used as the parent of a face wall.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- faceReference
- Type: Autodesk.Revit.DB Reference
The reference.
Return Value
True if the reference is valid as a parent to a face wall, false otherwise.Remarks
The reference must represent a face of a massing instance, and must be planar, and its normal must not be vertical or horizontal.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |