Creates a new opening in a roof, floor and ceiling.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostElement
- Type: Autodesk.Revit.DB Element
Host element of the opening. Can be a roof, floor, or ceiling.
- profile
- Type: Autodesk.Revit.DB CurveArray
Profile of the opening.
- bPerpendicularFace
- Type: System Boolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.
Return Value
If successful, an Opening object is returned.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the host element does not exist in the given document. |