Constructs a new FilteredElementCollector that will search and filter a specified set of elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document that owns the elements matching the element ids.
- elementIds
- Type: System.Collections.Generic ICollection ElementId
The input set of element ids.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input collection of ids was empty, or its contents were not valid for iteration. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |