Sets the relationship between the CurveElement and face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- curveElem
- Type: Autodesk.Revit.DB CurveElement
The CurveElement.
- sketchOnSurface
- Type: System Boolean
Whether or not the CurveElement should lie on the face and be able to be added to the face.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The input CurveElement is not a CurveByPoints. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |