Indicates if elements can be assigned to a new DisplacementElement.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view.
- elementIds
- Type: System.Collections.Generic ICollection ElementId
The element ids.
- commonDisplacedElementId
- Type: Autodesk.Revit.DB ElementId %
If this method returns true, then this is the element id of a DisplacementElement which lists all of elemIds among its displaced elements.
Return Value
Returns true if the specified element ids can be assigned to a new DisplacementElement.Remarks
A necessary condition is that isAllowedAsDisplacedElement returns true for each individual element id. In addition, if isElementDisplaced must return the same value for all the specified element ids.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |