Creates a sketch plane from a grid, reference plane, or level.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- datumId
- Type: Autodesk.Revit.DB ElementId
The id of the grid, reference plane, or level.
Return Value
The newly created sketch plane.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | datumId is not a valid Element identifier. -or- ElementId must correspond to a grid, reference plane, or level. -or- ElementId must correspond to a non-curved datum. -or- Sketch plane creation is not allowed in this family. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |