Add mullions on the specified segments of a grid. If any segment already has a mullion, no change is made to that segment.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- segment
- Type: Autodesk.Revit.DB Curve
Curve of the segment.
- mullionType
- Type: Autodesk.Revit.DB MullionType
The type of the mullion to add.
- oneSegmentOnly
- Type: System Boolean
If true, add one mullion to the specified segment, otherwise add mullions to all the segments of the matching grid line.
Return Value
If operation succeeds, the created mullions will be returned.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | Invalid curtain grid line or invalid mullion type argument. |