Sets the visibility of the elements associated with a filter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filterElementId
- Type: Autodesk.Revit.DB ElementId
The ElementId of the filter.
- visibility
- Type: System Boolean
True if the elements associated with the filter are visible in the view, false otherwise.
Remarks
If the filter is not currently applied to the view, this will add the filter with the specified visibility.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | ElementId is not associated with a FilterElement. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | View does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |