Sets the spatial element boundary location of a spatial element type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- spatialElementBoundaryLocation
- Type: Autodesk.Revit.DB SpatialElementBoundaryLocation
The boundary location.
- spType
- Type: Autodesk.Revit.DB SpatialElementType
The spatial element type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Currently only SpatialElementType.Room is permitted when setting the boundary location. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |